Is GeoServer ready for Java 1.5?
We’ve recently been kicking around the notion of requiring Java 1.5 to run GeoServer. There are a few nice features, such as generics and annotations, that are useful when you’re aiming to be a framework instead of just an application. And some potential libraries, like user interface ones, are starting to require Java 1.5. Other things pointing towards why it might be ok include the fact that Java will be open sourced soon, so it will be even easier for non core platforms to run GeoServer. But we figured the best way to figure out is to ask you, the users. If you have or are a sys admin who just isn’t ready to upgrade to Java 1.5, let us know. We realize that it’s a server application and admins like things stable. But with Java 1.6 out, and 1.5 very, very stable, we’re thinking it might be time. So please vote in the poll below, and place comments on this post if the options don’t do it for you. We will strongly take this feedback in to account for our decision.
- OGC Filter Injection Vulnerability Statement
- GeoServer 2.22.0 Release
- GeoServer 2.21.2 Release
- Jiffle and GeoTools RCE vulnerabilities
- GeoServer 2.20.4 Released
- Spring4Shell RCE vulnerability
- GeoServer 2.20.3 Released
- GeoServer 2.19.5 Released
- GeoServer 2.19.4 Released
- Log4J2 zero day vulnerability assessment